The WorkerThread Blog

we know stuff so you don't have to

Configure PDF IFilter in WSS 3.0

Posted by workerthread on January 3, 2008

There are various posts around on setting up MOSS 2007 to use the PDF IFilter, and some stuff on Windows SharePoint Services 3.0 as well.  I’ve found a method which works for me, so I wanted to put this together in one place – not least of all so I can find it when out on site with a client. 

Out of the box neither WSS 3 nor MOSS 2007 will index content located in Acrobat PDF files, so you need to set up the IFilter.  I’ve also found that that PDF files loaded prior to the installation of the filter won’t be re-crawled automatically, so to be on the safe side you might want to kick off a full crawl.

Here is what I’ve found works for WSS 3.0:

  1. First, you need to download the Adobe PDF IFilter 6.0, which you can find at this URL.  You should also get hold of a suitable Icon to use with PDFs, so that when they are listed in a document library they are easily recognisable.  There is a 17 x 17 one available on the Adobe web site here.
  2. Once you’ve downloaded the IFilter, install it on your WSS 3.0 server, and then follow the instructions on registry settings in Microsoft KB Article 927675.  I’ve always found that providing the Adobe IFilter installed properly, the only setting I need to add is the Search Extensions one listed in step 2.  Also note step 5 re stopping and re-starting the search service.
  3. Now you need to set up the Icon file.  If you downloaded the icon file in step 1 above, you will have a file called pdficon_small.gif.  You need to copy this onto your WSS 3.0 server, into drive:\Program Files\Common FIles\Microsoft Shared\Web Server extensions\12\TEMPLATE\IMAGES.
  4. Next you need to edit the XML file which WSS uses to link file extensions to icons.  This file is called DOCICON.XML and is located at drive:\Program Files\Common FIles\Microsoft Shared\Web Server extensions\12\TEMPLATE\XML.  Navigate to that folder and locate the file.  I would suggest making a backup copy first, then opening the file in NotePad.  You need to add a mapping key for PDFs at the bottom of the file, above the </ByExtension> closing tag.  The new key will be <Mapping Key=”pdf” Value=”pdficon_small.gif” OpenControl=””/>  (note that XML is case sensitive so make sure you use same case as previous entries).  Then save the file.
  5. That’s pretty much it, but if you already have PDFs uploaded to your WSS server I would recommend starting a full crawl.  You can do the with STSAdm, the command syntax is Stsadm -o spsearch -action fullcrawlstart .  More on this on TechNet here.
Technorati tags: , ,
About these ads

48 Responses to “Configure PDF IFilter in WSS 3.0”

  1. ravie14 said

    Hello,
    I did all as written above – the icon is displayed, the registry keys present, full crawl done. However, no pdf in search results. Certainly, I do not expect the system to find a string in scanned documents (suppose there is some OCR needed – this would be maybe another good topic), but even if I upload a “Save doc as pdf”-from-MS-Word document, nothing.
    Any ideas?
    Btw, the article is very good.
    Thanks!
    Ravie.

  2. [...] my earlier post on the subject, I referenced the downloadable version 6.0 IFilter. ServerGrrl’s post makes the point that [...]

  3. Ravie

    See my latest post today which talks about Acrobat Reader 8.0. It could be that the PDFs you are crawling aren’t readable by the version 6.0 IFilter so maybe try Acrobat Reader 8.0?

    Derek

  4. ravie14 said

    Derek, thank you.
    I’ll try the version mentioned and let you know.
    Best regards,
    Ravie.

  5. ravie14 said

    Well, I tried the Servergrrl’s article, and no luck. It’s not working so far. I’ll try it once more :-/

  6. 5 SharePoint Hacks End Users Love…

    “How do we best customize SharePoint so that our end users ……

  7. Gopakumar Adichan said

    Hi there,
    Thanks for the post.

    I did install the filter.
    But when I look for
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Shared Tools\Web Server Extensions\12.0\Search\Applications\GUID\Gather\Search\Extensions\ExtensionList

    I could see up to the GUID .Under GUID I don’t see Gather directory .Should I add Gather\Search\Extension\ExtensList

    thank you Gopa

  8. Gopa,

    I don’t see how WSS Search is working correctly if you don’t have a set of subkeys under the GUID (which stands for Globally Unique ID of course). Under the subkey HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Shared Tools\Web Server Extensions\12.0\Search\Applications\\Gather\Search\Extensions\ExtensionList\ there will be a list of extensions which WSS search is crawling.

    Derek

  9. Chris Eidsmoe said

    Thanks for the good blog post- However, I can’t even finish the install on my WSS 3.0 server, the iFilter install just “disappears” and there are processes running that I see in task manager for iFilter and setup.exe but they dont’ run! Any ideas? Thank you.

  10. Hi Chris,

    I haven’t experienced any setup issues myself. Is it version 6 of IFilter you are trying to install? Just a wild guess – could it be permissions related (do you have admin rights on the server?).

    Only other thing I could suggest would be if your problem is with the v6 IFilter, cancel the install process and install Acrobat Reader 8 or 9 instead, then configure WSS acordingly. A little more info on Acrobat reader 9 here https://workerthread.wordpress.com/2008/07/18/adobe-reader-9-available-works-fine-with-sharepoint/ .

    Can’t guarantee anything though….

    Derek

  11. Granada said

    After I stoped my Search service. I was not able to restart search again. It kept giving me error that the DB already exists and it need to be an empty. Remove all tables and stored procedures. So I startted the search service using new DB. Also ran full crawl. But search is not working anymore on my site. Please help.

  12. Granada

    I haven’t seen this error myself but there are a lot of posts/queries about it online. Try searching for the error message you are seeing and you will get lots of results, for example this one http://bit.ly/4b75rK and this one – http://technetlk.blogspot.com/2007/05/wsssearch.html . Could be you need to create a new search database.

    Derek

  13. ClaireGarrick said

    Hope this helps:

    in Microsoft KB Article 927675 it says to edit the registry and check these SUBkeys:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Shared Tools\Web Server Extensions\12.0\Search\Setup\ContentIndexCommon\Filters\Extension\.pdf
    This registry subkey must contain the following registry entry:
    • Name: Default
    Type: REG_MULTI_SZ
    Data: {4C904448-74A9-11D0-AF6E-00C04FD8DC02}

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Shared Tools\Web Server Extensions\12.0\Search\Setup\Filters\.pdf
    This registry subkey must contain the following registry entries:
    • Name: Default
    Type: REG_SZ
    Data: (value not set)
    • Name: Extension
    Type: REG_SZ
    Data: pdf
    • Name: FileTypeBucket
    Type: REG_DWORD
    Data: 0×00000001 (1)
    • Name: MimeTypes
    Type: REG_SZ
    Data: application/pdf

    I had to double check my settings when I still couldn’t search PDF’s when I made the changes suggested. Sure enough, my GUID was this: {E8978DA6-047F-4E3D-9C78-CDBE46041603}
    I have version 9.0 of Adobe reader installed on the server.
    I replaced this GUID {4C904448-74A9-11D0-AF6E-00C04FD8DC02} with this GUID {E8978DA6-047F-4E3D-9C78-CDBE46041603}

    Don’t change the GUID under HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Shared Tools\Web Server Extensions\12.0\Search\Applications\\Gather\Search\Extensions\ExtensionList\38

    After that change and a reboot, I was searching PDF’s.
    Also check that your application is using a search server. This is in addition to checking that your search server is running.

  14. [...] it Easier Please? The two posts on this blog with the greatest number of hits are the one on configuring a PDF iFilter with WSS 3.0, and using Adobe Reader 9 with SharePoint.  Almost every SharePoint implementation I’ve [...]

  15. [...] https://workerthread.wordpress.com/2008/01/03/configure-pdf-ifilter-in-wss-30/ [...]

  16. Kerry Nicponski said

    The article ClaireGarrick pasted from solved my in-document searches issue for PDF’s. If you have run the ifilter 6.0 on the same machine as you have your database server on, then double check the keys and values mentioned in the article (and pasted in the post above), then the the net stop spsearch, net start spsearch the install is set.

    Bad news is, any pdf’s you already uploaded don’t get in the index and I could not find a way to force a re-index. So I deleted and mass reloaded all the pdf’s. BAM… in document search was viable and everyone lived happily ever after.

    To the poster above who asked about adding keys… don’t do it… I almost made that mistake. If the keys are not where the KB article says they are, you have a bad install of the ifilter 6.0 OR you are on the wrong server. Don’t laugh, I searched my local machine thinking i was remoted in to the server, not finding any keys, I almost created them… then I snapped out of my cluelessness and remoted into the wrong server, but this time I realized i was on the wrong server as soon as I did not see the key values. Once I brilliantly located the correct server, the only key value I had to add was the number “38″. And reload all the pdf’s.

  17. Kerry: regarding re-indexing PDFs uploaded before you install the filter, see point 5 of my original post – you can do this with the STSADM command STSADM -o spsearch -action fullcrawlstart

    Derek

  18. [...] of PDF, iFilter, WSS, MOSS etc and these visitors click through to one of the PDF related posts here, here and [...]

  19. [...] Configure PDF IFilter in WSS 3.0 [...]

  20. Bey said

    hi,
    i had followed all the 5 steps as above.
    i had successful installed and configured the IFilter.
    After i done the crawl, i can get the full text search results for the pdf file.
    but my problem is it cannot show the pdf icon for my pdf file,but it shown the IE icon.
    what wrong with my setting?
    thank you very much………….

    • Bey: If you aren’t displaying the pdf icon, I would first check that the icon file (pdficon_small.gif or whatever yours is) is in the correct location \Program Files\Common FIles\Microsoft Shared\Web Server extensions\12\TEMPLATE\IMAGES.

      I would also double-check that you have correctly created the entry in \Program Files\Common FIles\Microsoft Shared\Web Server extensions\12\TEMPLATE\XML.

      If you are sure that both of these are correct, then I would suggest performing an IISReset/Noforce (at a time suitable for your users of course) to see if this does the trick.

      Derek

  21. [...] credits, this post is gathered from a few sources: Clearest post on .pdf search out there How to insert the pdf icon If this post doesn’t work out for you (SharePoint environments differ greatly) you could try [...]

  22. [...] Bing search returned one of my blog posts in fourth place, as you can see [...]

  23. insy09 said

    very informative this posts shows some tweaks for 64 bit.. and some more ifilters that might be useful.

    http://zebracube.wordpress.com/2009/06/21/pdf-ifilter-sharepoint/

  24. denman said

    Thnx, installed it like you described, and it works!!

  25. Brian said

    Thanks for the easy to follow steps, I am having difficulty with the “icon” piece. Did you have any issues with the icon not showing up immediately? Did you need to restart and Sharepoint services to get it to show properly?

    Thanks
    Brian

    • Hi Brian

      I’ve seen some instances where IISReset/Noforce was required. Make sure you know what IISReset does and how it affects logged in users before you do this.

      Derek

  26. [...] PDF Indexing Support in SharePoint The most popular post on this blog is still the one about Configuring PDF iFilter for WSS 3.0.  Today I saw a post on Notes for .Net which may help to automate this multi-step [...]

  27. Hi,

    Great post. I greated a nice feature to implement the pdf icon.

    Take a look here:
    http://www.blogaboutsharepoint.com/2009/06/25/feature-for-adding-the-pdf-icon-to-your-sharepoint-farm/

  28. Manasi said

    Hi,

    Even I followed the above steps. But am able to only search the title of pdf document and not the full context search. Please guide me in this.. what should I do for full context pdf search?

    Thanx in advance

    • Well, the steps outlined above definitely work. If you aren’t able to search inside PDFs then most likely due to something not quite right with setup, maybe registry entries or something.

      Also don’t forget that once everything is set up you MUST do a full crawl, otherwise previously uploaded PDFs won’t be indexed.

  29. Richard said

    Excellent, thank you for the walk through

  30. DonB said

    Hi,
    Using the above post, I was able to get our PDF searching and icon functionality working. This post was gold.

    That said, an unforseen consequence is this: Users are now unable to upload PDF documents without WSS requesting credentials and even then won’t accept them without some argument. If they click OK enough, it will upload the document, but the icon portion of the shared document shows a red x and the file name. Already uploaded pdf docs automatically show the aforementioned red x and file name.

    It has to be a permissions issue since I don’t get those symptoms as an adminsitrator with full control. Everything looks and performs as it should.

    Thoughts?

    Cheers,
    Don

  31. DonB said

    Disregard the above. A more extensive search revealed the fix: Once you uplade the pdf icon to the IMAGES directory, it needs to have the Users group added to the security tab or it will not display properly for those with lesser permissions.

    Don

    • Hi Don

      Glad you fixed it (although I haven’t ever come across this problem myself).

      Thanks for updating the comments and I hope other readers find it useful.

      Derek

  32. Hi All,
    I have published an article at http://www.mossgurus.com/adnan/default.aspx explaining How to Install and configure PDF iFilter (64 bit) for SharePoint Server 2010 or Search Server 2010 Express with screen shots of each important steps.
    I do hope that you will find this article useful. Please leave your comments.
    Thanks
    Adnan Ahmed
    Senior MS Solutions Consultant
    Owner: http://www.mossgurus.com

  33. [...] : https://workerthread.wordpress.com/2008/01/03/configure-pdf-ifilter-in-wss-30/ Posted in Windows | Tags: SharePoint, Windows « Configure Windows SharePoint Services [...]

  34. [...] http://www.tech-archive.net/Archive/SharePoint/microsoft.public.sharepoint.portalserver/2008-11/msg00009.html https://workerthread.wordpress.com/2008/01/03/configure-pdf-ifilter-in-wss-30/ [...]

  35. [...] https://workerthread.wordpress.com/2008/01/03/configure-pdf-ifilter-in-wss-30/ Posted on 27 september 2010 by Digitcon ← Deployen van een solution bijft op status [...]

  36. [...] https://workerthread.wordpress.com/2008/01/03/configure-pdf-ifilter-in-wss-30/ [...]

  37. Doug said

    Helpful post, but still having difficulty seeing any results. Forced a full crawl, and the Registry looks good except the one GUID is a different value than the MSKB article.

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Shared Tools\Web Server Extensions\12.0\Search\Setup\ContentIndexCommon\Filters\Extension\.pdf

    I’m using WSS3.0 on a W2008 64-but server, and installed the Adobe PDF iFilter 9 for 64-bit platforms.

    • Hi Doug

      I haven’t used the 64-bit iFilter with WSS 3 but have done several successful 64-bit installs on SharePoint 2007 and Search Server Express.

      I notice there are a couple of 64-bit specific blog posts on this here and here, don’t know if they will help?

      Derek

  38. navaz said

    Hello,

    I have a problem,.

    How can i do custom search in sharepoint 2010..

    actually i need if a keyword is searched..

    that keyword can be search within the pdf and then result in format of in which file that keyword is present , location of file having keyword, file name ,..etc

    so please suggestion on this custom search.

    Advance Thanks
    NavazShaik

  39. Jonniestyle said

    I just ran thru all the steps, and everything looks great, but no PDF returns are happening, either…

  40. Tim said

    Here is what worked for WSS 3.0 on Win2k3

    1. Download and then install the Adobe PDF 9.4
    2. Add the following registry entry, and then set the registry entry value to pdf:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Shared Tools\Web Server Extensions\12.0\Search\Applications\\Gather\Search\Extensions\ExtensionList\38
    To do this, follow these steps:
    a. Click Start, click Run, type regedit, and then click OK.
    b. Locate and then click the following registry subkey:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Shared Tools\Web Server Extensions\12.0\Search\Applications\GUID\Gather\Search\Extensions\ExtensionList
    c. On the Edit menu, point to New, and then click String Value.
    d. Type 38, and then press ENTER.
    e. Right-click the registry entry that you created, and then click Modify.
    f. In the Value data box, type pdf, and then click OK.
    3. Verify that the following two registry subkeys are present and that they contain the appropriate values.

    Note These registry subkeys and the values that they contain are created when you installed the Adobe PDF IFilter on the server.
    o HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Shared Tools\Web Server Extensions\12.0\Search\Setup\ContentIndexCommon\Filters\Extension\.pdf
    This registry subkey must contain the following registry entry:
     Name: Default
    Type: REG_MULTI_SZ
    Data: {E8978DA6-047F-4E3D-9C78-CDBE46041603}
    o HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Shared Tools\Web Server Extensions\12.0\Search\Setup\Filters\.pdf
    This registry subkey must contain the following registry entries:
     Name: Default
    Type: REG_SZ
    Data: (value not set)
     Name: Extension
    Type: REG_SZ
    Data: pdf
     Name: FileTypeBucket
    Type: REG_DWORD
    Data: 0×00000001 (1)
     Name: MimeTypes
    Type: REG_SZ
    Data: application/pdf
    4. Upload the PDF documents to the Windows SharePoint Services 3.0 Web site.
    5. Stop and then start the Windows SharePoint Services Search service. To do this, follow these steps:
    . Click Start, click Run, type cmd, and then click OK.
    a. Stop the Windows SharePoint Services Search service. To do this, type net stop spsearch at the command prompt, and then press ENTER.
    b. Start the Windows SharePoint Services Search service. To do this, type net start spsearch at the command prompt, and then press ENTER.
    c. Type exit to exit the command prompt.

  41. [...] Learn how to configure the PDF Ifilter from: The Worker Thread Blog. [...]

Sorry, the comment form is closed at this time.

 
%d bloggers like this: